kaberett: Overlaid Mars & Venus symbols, with Swiss Army knife tools at other positions around the central circle. (Default)
[personal profile] kaberett
I remembered from last time that several of these points were trivial to resolve but I didn't remember how they were trivial to resolve and my wry comments didn't actually include details. ERGO.

  • Not Sid.
  • Downgrades are a nice idea but frequently get Stuck.
  • For entirely baffling reasons, the way to boot from the grub prompt was to follow the standard set of instructions with no USB drives and a CD inserted -- mysteriously, correctly pointing at hd1/hd2 didn't play ball, but once the relevant partition was on hd0 it was fine.
  • update-grub meant it worked on reboot.
  • You always want to install network-manager. Its absence is usually the problem with wifi.
  • Per the wiki, the touchpad (even though it's ALPS, yes) is sorted out by installing xserver-xorg-input-synaptics.
  • Installed python3. Attempted to install veusz-1.25 from source. It did not. Installed pip. Installed sip. veusz setup claimed it could not see pip. -- offs, veusz-1.21 (from Debian repository) claims I'm missing python-astropy and python-sampy. -astropy is trivially fixable, -sampy is not.
    • okay let's try doing this the hard way.
    • installed sip .tar.gz and unpacked using python3 (python3 configure.py)
    • ... ffs. sudo apt-get install build-essentials, because apparently g++ wasn't a thing.
    • apt-get install python3-dev (and also python-dev for good measure)
    • make ran!
    • so did sudo make install!
    • okay now it's time to do the same wretched process for PyQt4 apparently.
    • sudo apt-get install python3-pyqt4
    • sudo apt-get install libqt4-dev
    • (inside unpacked PythonQt4 folder) python3 configure-ng.py; make; sudo make install
    • (inside veusz folder) python3 setup.py build (holy shit it worked)
    • sudo python3 setup.py install (... wORKED???)
    • ... running veusz gets me "the sip module implements API v11.0 to v11.3 but the [WTF-8] module requires API v12.1"
    • see here: did apt-get remove on the repository packages, and redid sudo make install for both sip and PyQt4. VEUSZ NOW LOADS. For my next trick, I will work out how to get it into the bloody main menu.

  • sudo apt-get install mate-menu
  • system-config-printer might have been useful but just see SystemPrinting and do the obvious

(no subject)

Date: 2017-04-10 02:24 pm (UTC)
sporky_rat: Legion, being serious.  As a Geth, he can't not be serious.  (Group Seriousness)
From: [personal profile] sporky_rat
There's a saying among the A&S folks in my kingdom: 'Documentation or you're gonna cry later'.
(Not where I expected that saying to end, but I like it better.)

Profile

kaberett: Overlaid Mars & Venus symbols, with Swiss Army knife tools at other positions around the central circle. (Default)
kaberett

July 2017

M T W T F S S
     12
3456789
101112 131415 16
1718 192021 2223
24252627282930
31      

Most Popular Tags

Page Summary

Style Credit

Expand Cut Tags

No cut tags
Powered by Dreamwidth Studios